Commit d91ecc91 authored by Paul McCarthy's avatar Paul McCarthy 🚵
Browse files

ENH: New platform-specific package lists in case e.g. we need to pin

dependencies differently. Associated [purely cosmetic] changes to some
identifiers (underscores -> hyphens)
parent 2467daf3
......@@ -3,7 +3,7 @@
# file is assumed to be downloadable from this URL.
# URLs for newly generated environment files are
# constructed using this URL.
release_url: https://fsl.fmrib.ox.ac.uk/fsldownloads/fslconda/releases/
release-url: https://fsl.fmrib.ox.ac.uk/fsldownloads/fslconda/releases/
# Latest fslinstaller version
installer: 1.4.3
......@@ -32,13 +32,13 @@ channels:
# Private internal channel for development and
# testing releases. This is prepended to the
# channels list for development releases.
internal_channel: http://${FSLCONDA_USERNAME}:${FSLCONDA_PASSWORD}@fsl.fmrib.ox.ac.uk/fsldownloads/fslconda/internal/
internal-channel: http://${FSLCONDA_USERNAME}:${FSLCONDA_PASSWORD}@fsl.fmrib.ox.ac.uk/fsldownloads/fslconda/internal/
# The FSL installation is created in two stages.
# First of all, the base_packages are installed.
# Versions of these packages are specified in
# the packages list below
base_packages:
base-packages:
- fslpy
- fsl-base
- fsl-sub
......@@ -186,3 +186,14 @@ packages:
- nidmresults 2.1.0
- nidmresults-fsl 2.2.0
- openslide-python v1.1.2
# List of additional packages that
# are added to linux-64 installations.
linux-64-packages: []
# List of additional packages that
# are added to macos-64 installations.
macos-64-packages:
# Newer libffi causes FSLeyes to segfault:
# https://github.com/conda-forge/pyobjc-core-feedstock/issues/37
- libffi 3.3
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment