really make deprecation dependency less strict

5 jobs for 1.7.0 in 3 minutes and 28 seconds (queued for 1 second)
latest
Status Name Job ID Coverage
  Build
failed build-conda-dist #21747
docker

00:00:59

100.0%
passed build-pypi-dist #7755
docker

00:01:15

passed build-conda-dist #7756
docker

00:09:25

100.0%
 
  Deploy
passed deploy-conda #7758
docker manual

00:00:31

passed deploy-pypi #7757
docker manual

00:00:42

 
Name Stage Failure
failed
build-conda-dist Build
    create_build_envs(top_level_pkg, notest)
File "/opt/conda/lib/python3.7/site-packages/conda_build/build.py", line 1291, in create_build_envs
raise e
File "/opt/conda/lib/python3.7/site-packages/conda_build/build.py", line 1281, in create_build_envs
channel_urls=tuple(m.config.channel_urls))
File "/opt/conda/lib/python3.7/site-packages/conda_build/environ.py", line 758, in get_install_actions
raise DependencyNeedsBuildingError(exc, subdir=subdir)
conda_build.exceptions.DependencyNeedsBuildingError: Unsatisfiable dependencies for platform linux-64: {"deprecation[version='>=1.*,<=2.*']", 'nibabel=2'}
ERROR: Job failed: exit code 1