Merge branch 'bf/plotpanellimits' into 'master'

Fix an issue with plot canvas limits

See merge request fsl/fsleyes/fsleyes!246
5 jobs for master in 2 minutes and 53 seconds
latest
Status Name Job ID Coverage
  Test
canceled test:3.7 #38683
docker

00:02:53

canceled test:3.8 #38684
docker

00:02:53

canceled test:3.9 #38685
docker

00:02:52

failed test:build-pypi-dist #38686
docker

00:01:20

 
  Style
canceled style #38687
docker

 
Name Stage Failure
failed
test:build-pypi-dist Test
Requirement already satisfied: six in /test.venv/lib/python3.7/site-packages (from cycler>=0.10->matplotlib>=1.5.1->fsleyes==1.1.0.dev0) (1.15.0)
Requirement already satisfied: packaging>=14.3 in /test.venv/lib/python3.7/site-packages (from nibabel>=2.3->fsleyes==1.1.0.dev0) (20.9)
Installing collected packages: pyopengl, fsleyes
Successfully installed fsleyes-1.1.0.dev0 pyopengl-3.1.5
WARNING: You are using pip version 21.0.1; however, version 21.1.1 is available.
You should consider upgrading via the '/test.venv/bin/python3.7 -m pip install --upgrade pip' command.
Exception ignored in: <_io.TextIOWrapper name='<stdout>' mode='w' encoding='UTF-8'>
OSError: [Errno 9] Bad file descriptor
ERROR: Job failed: exit code 1