Commit bcf343a6 authored by Paul McCarthy's avatar Paul McCarthy 🚵
Browse files

Merge branch 'rel/0.34.1' into 'v0.34'

Rel/0.34.1

See merge request fsl/fsleyes/fsleyes!216
parents e59486b6 bb5572bc
......@@ -9,6 +9,20 @@ This document contains the ``fsleyes`` release history in reverse
chronological order.
0.34.1 (Monday 13th July 2020)
------------------------------
Fixed
^^^^^
* Fixed an issue with Jupyter Notebook integration on conda+macOS installations
(!215).
* Fixed an issue with the high-DPI option not appearing in the view settings panel
under macOS (!215).
0.34.0 (Wednesday 8th July 2020)
--------------------------------
......
......@@ -144,7 +144,7 @@ class CanvasSettingsPanel(ctrlpanel.SettingsPanel):
# The highDpi setting is
# only relevant on macOS
if platform.system != 'Darwin':
if platform.system() != 'Darwin':
sceneOptsProps.pop('highDpi')
def _displaySpaceOptionName(opt):
......
......@@ -196,12 +196,6 @@ log = logging.getLogger(__name__)
os.environ.pop('LIBGL_ALWAYS_INDIRECT', None)
# If there is no display, assume we're
# running in off-screen / OSMesa mode.
if not fslplatform.canHaveGui:
os.environ['PYOPENGL_PLATFORM'] = 'osmesa'
import OpenGL # noqa
......
......@@ -14,7 +14,7 @@ version number. See also the :mod:`fsl.version` module.
"""
__version__ = '0.34.0'
__version__ = '0.34.1'
"""Current version number, as a string. The FSLeyes version number consists
of three numbers, separated by a period, which roughly obeys the Semantic
Versioning conventions (http://semver.org/).
......
......@@ -30,7 +30,7 @@ From FSL 6.0.2 onwards, FSLeyes is installed into the ``fslpython`` conda
environment, which is a part of the FSL installation. You can update to the
latest version of FSLeyes by running the following command::
$FSLDIR/fslpython/bin/conda update -n fslpython -c conda-forge fsleyes
$FSLDIR/fslpython/bin/conda update -n fslpython -c conda-forge --update-deps fsleyes
FSL 6.0.1 and older
......@@ -55,7 +55,7 @@ Now you can install FSLeyes with the following command::
When you want to update FSLeyes again in the future, use this command instead::
$FSLDIR/fslpython/bin/conda update -n fslpython -c conda-forge fsleyes
$FSLDIR/fslpython/bin/conda update -n fslpython -c conda-forge --update-deps fsleyes
Install from ``conda-forge`` (recommended)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment