Commit 0e43ca5d authored by Paul McCarthy's avatar Paul McCarthy
Browse files

Do we have gitlab-ci available?

parent e20fff6e
image: python:2.7
test:
- cat requirements.txt | xargs -n 1 pip install
- python setup.py test
cython>=0.24
six>=1.10.0
numpy>=1.11.1
matplotlib>=1.5.1
nibabel>=2.0.2
git+https://github.com/pauldmccarthy/indexed_gzip.git#egg=indexed_gzip
git+ssh://git@git.fmrib.ox.ac.uk/paulmc/props.git#egg=props
[aliases]
test=pytest
\ No newline at end of file
...@@ -23,6 +23,11 @@ version = {} ...@@ -23,6 +23,11 @@ version = {}
with open(op.join(basedir, "fsl", "version.py")) as f: with open(op.join(basedir, "fsl", "version.py")) as f:
exec(f.read(), version) exec(f.read(), version)
install_requires = open(op.join(basedir, 'requirements.txt'), 'rt').readlines()
dependency_links = [i for i in install_requires if i.startswith('git')]
install_requires = [i for i in install_requires if not i.startswith('git')]
setup( setup(
name='fslpy', name='fslpy',
...@@ -48,12 +53,10 @@ setup( ...@@ -48,12 +53,10 @@ setup(
packages=find_packages(exclude=('doc')), packages=find_packages(exclude=('doc')),
install_requires=[ install_requires=install_requires,
'pyopengl>=3.1.0', dependency_links=dependency_links,
'pyparsing>=2.0.3',
'numpy>=1.8.1', setup_requires=['pytest-runner'],
'scipy>=0.14.0', tests_require=['pytest', 'pytest-runner'],
'matplotlib>=1.3.1', test_suite='tests',
'nibabel>=1.3.0',
'Pillow>=2.5.3'],
) )
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment